<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.sakafete.com/wp-content/uploads/2020/05/favicon.ico">
<link rel="pingback" href="https://www.sakafete.com/xmlrpc.php" />
<!-- Global site tag (gtag.js) - Google Analytics Start -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1472193-21"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1472193-21');
</script>
<!-- Global site tag (gtag.js) - Google Analytics End-->
<!-- Google Total site ads start -->
<script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Google Total site ads Ends  -->

<!-- CAKAFETEINC Analytics tracking code -->
<script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.www.sakafete.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://cakafeteinc.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '2']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="https://cakafeteinc.com/matomo.php?idsite=2&amp;rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End sakafete Code -->

<script>!function(e){var n={};function r(t){if(n[t])return n[t].exports;var o=n[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,r),o.l=!0,o.exports}r.m=e,r.c=n,r.d=function(e,n,t){r.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:t})},r.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},r.t=function(e,n){if(1&n&&(e=r(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(r.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)r.d(t,o,function(n){return e[n]}.bind(null,o));return t},r.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return r.d(n,"a",n),n},r.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},r.p="",r(r.s=0)}([function(e,n){!function(e){var n=e.ampUrl,r=e.isCustomizePreview,t=e.isAmpDevMode,o=e.noampQueryVarName,i=e.noampQueryVarValue,a=e.disabledStorageKey,u=e.mobileUserAgents,s=e.regexRegex;if("undefined"!=typeof sessionStorage){var c=new RegExp(s);if(u.some((function(e){var n=e.match(c);if(n&&new RegExp(n[1],n[2]).test(navigator.userAgent))return!0;return navigator.userAgent.includes(e)}))){document.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var n=e.querySelector("a[href]");n&&n.addEventListener("click",(function(){sessionStorage.removeItem(a)}))}}));var f=t&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(a)||r||f)){var d=new URL(location.href);d.searchParams.has(o)&&i===d.searchParams.get(o)?sessionStorage.setItem(a,"1"):(window.stop(),location.replace(n))}}}}({"ampUrl":"https:\/\/www.sakafete.com\/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}]);</script>
<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC</title>
<meta name="description" content="MSNBC delivers breaking news, in-depth analysis of politics headlines, as well as commentary and informed perspectives. Find video clips and segments from The"/>
<meta name="robots" content="index, nofollow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC">
<meta property="og:description" content="MSNBC delivers breaking news, in-depth analysis of politics headlines, as well as commentary and informed perspectives. Find video clips and segments from The">
<meta property="og:url" content="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/">
<meta property="og:site_name" content="Dominica news online most popular | cakafete">
<meta property="article:publisher" content="https://facebook.com/cakafete">
<meta property="article:author" content="https://facebook.com/cakafete">
<meta property="article:tag" content="American attorney">
<meta property="article:tag" content="Amy Jean Klobuchar">
<meta property="article:tag" content="Amy Klobuchar">
<meta property="article:tag" content="Ari Melber">
<meta property="article:tag" content="Best of last night">
<meta property="article:tag" content="Chris Krebs">
<meta property="article:tag" content="Christopher C. Krebs">
<meta property="article:tag" content="current events">
<meta property="article:tag" content="donald trump">
<meta property="article:tag" content="elections">
<meta property="article:tag" content="Emmy">
<meta property="article:tag" content="Emmy-winning executive producer">
<meta property="article:tag" content="Homeland Security">
<meta property="article:tag" content="Infrastructure Security Agency">
<meta property="article:tag" content="Last Word">
<meta property="article:tag" content="Lawrence O&#039;Donnell">
<meta property="article:tag" content="lawrence odonnell live">
<meta property="article:tag" content="Liberal News">
<meta property="article:tag" content="MSNBC">
<meta property="article:tag" content="MSNBC Live">
<meta property="article:tag" content="MSNBC News">
<meta property="article:tag" content="news">
<meta property="article:tag" content="Nicolle Wallace">
<meta property="article:tag" content="Online Visit">
<meta property="article:tag" content="President Trump fired">
<meta property="article:tag" content="Progressive News">
<meta property="article:tag" content="Senate Finance Committee">
<meta property="article:tag" content="The Last Word">
<meta property="article:tag" content="The Last Word with Lawrence O&#039;Donnell">
<meta property="article:tag" content="The Rachel Maddow Show">
<meta property="article:tag" content="United States Department">
<meta property="article:tag" content="United States Senator">
<meta property="article:tag" content="us news">
<meta property="article:tag" content="White House">
<meta property="article:section" content="The Top News Today">
<meta property="og:updated_time" content="2020-11-18T23:05:55-05:00">
<meta property="fb:app_id" content="100001021166193">
<meta property="og:image" content="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251.jpg">
<meta property="og:image:secure_url" content="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251.jpg">
<meta property="og:image:width" content="1280">
<meta property="og:image:height" content="720">
<meta property="og:image:alt" content="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC">
<meta property="og:image:type" content="image/jpeg">
<meta property="og:video" content="https://www.youtube.com/embed/bvrgkVTcgH8?feature=oembed">
<meta property="ya:ovs:upload_date" content="2020-11-18EST23:05:49-05:00">
<meta property="ya:ovs:allow_embed" content="true">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC">
<meta name="twitter:description" content="MSNBC delivers breaking news, in-depth analysis of politics headlines, as well as commentary and informed perspectives. Find video clips and segments from The">
<meta name="twitter:site" content="@cakafete">
<meta name="twitter:creator" content="@cakafete">
<meta name="twitter:image" content="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251.jpg">
<script type="application/ld+json" class="rank-math-schema-pro">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</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//www.sakafete.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Feed" href="https://www.sakafete.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Comments Feed" href="https://www.sakafete.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC Comments Feed" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sakafete.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.sakafete.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpbloom-css'  href='https://www.sakafete.com/wp-content/plugins/bloom/public/css/wpbloom-public.css?ver=1.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='one-click-video-site-builder-front-css'  href='https://www.sakafete.com/wp-content/plugins/one-click-video-site-builder/assets/css/front.css?ver=1.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='https://www.sakafete.com/wp-content/themes/mh_newsdesk/style.css?ver=1.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.sakafete.com/wp-content/themes/mh_newsdesk/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700%7cOswald:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/bloom/public/js/wpbloom-public.js?ver=1.5.1' id='wpbloom-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/one-click-video-site-builder/assets/js/front.js?ver=1.3.12' id='one-click-video-site-builder-front-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=5.5.3' id='mh-scripts-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-1472193-21' id='google_gtagjs-js'></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.sakafete.com"]} );
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-1472193-21');
</script>
<link rel="https://api.w.org/" href="https://www.sakafete.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sakafete.com/wp-json/wp/v2/posts/85324" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sakafete.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sakafete.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://www.sakafete.com/?p=85324' />
<link rel="alternate" type="application/json+oembed" href="https://www.sakafete.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sakafete.com%2Fklobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sakafete.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sakafete.com%2Fklobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc%2F&#038;format=xml" />
	<meta name="keywords" content="American attorney, Amy Jean Klobuchar, Amy Klobuchar, Ari Melber, Best of last night, Chris Krebs, Christopher C. Krebs, current events, donald trump, elections, Emmy, Emmy-winning executive producer, Homeland Security, Infrastructure Security Agency, Last Word, Lawrence O'Donnell, lawrence odonnell live, Liberal News, MSNBC, MSNBC Live, MSNBC News, news, Nicolle Wallace, Online Visit, President Trump fired, Progressive News, Senate Finance Committee, The Last Word, The Last Word with Lawrence O'Donnell, The Rachel Maddow Show, United States Department, United States Senator, us news, White House" />
<!--[if lt IE 9]>
<script src="https://www.sakafete.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="amphtml" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/amp/"><style>#amp-mobile-version-switcher {
	position: absolute;
	width: 100%;
	left: 0;
	z-index: 100;
}

#amp-mobile-version-switcher > a {
	display: block;
	padding: 15px 0;
	font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;
	font-size: 16px;
	font-weight: 600;
	color: #eaeaea;
	text-align: center;
	text-decoration: none;
	background-color: #444;
	border: 0;
}

#amp-mobile-version-switcher > a:hover,
#amp-mobile-version-switcher > a:focus,
#amp-mobile-version-switcher > a:active {
	text-decoration: underline;
}
</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/?amp=1"><link rel="icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-270x270.png" />
</head>
<body class="post-template-default single single-post postid-85324 single-format-video mh-right-sb mh-loop-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div id="mh-wrapper">
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo">
			<a href="https://www.sakafete.com/" title="Dominica news online most popular | cakafete" rel="home">
<div class="logo-wrap" role="banner">
<div class="logo">
<h1 class="logo-title">Dominica news online most popular | cakafete</h1>
<h2 class="logo-tagline">Local, Reginald and International Latest News</h2>
</div>
</div>
</a>
		</div>
		<aside id="custom_html-6" class="widget_text mh-col mh-2-3 widget_custom_html"><div class="widget_text header-ad"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Review Products -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="8380539043"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>	</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-submit-container"><ul id="menu-submit" class="menu"><li id="menu-item-11407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11407"><a href="https://www.sakafete.com/latest-buzz/">LATEST BUZZ</a></li>
<li id="menu-item-1620" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1620"><a href="https://www.sakafete.com/dominica-to-open-celebrations-for-reunion-year-2008-with-grand-reunion-wive-activity/">Celebs/Artist News</a></li>
<li id="menu-item-1621" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1621"><a href="https://www.sakafete.com/prime-minister-skerrit-highlights-the-incidence-of-chronic-non-communicable-diseases-in-dominica/">Publication</a></li>
<li id="menu-item-1622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1622"><a href="https://www.sakafete.com/myblog-2/">Dominicans Open Blogs</a></li>
<li id="menu-item-64991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64991"><a href="https://www.sakafete.com/caribbean-tourism-in-the-tropical-islands/">Tourism News</a></li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<div id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">
			Hot Topics		</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/lawrence-another-day-another-trump-vengeance-firing-the-last-word-msnbc/" title="Lawrence: ‘Another Day, Another Trump Vengeance Firing’ | The Last Word | MSNBC">
					<span class="ticker-item-date">November 18, 2020</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Lawrence: ‘Another Day, Another Trump Vengeance Firing’ | The Last Word | MSNBC</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/" title="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC">
					<span class="ticker-item-date">November 18, 2020</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/dr-bhadelia-trump-admin-hurting-people-by-not-sharing-covid-19-info-with-biden-the-last-word/" title="Dr. Bhadelia: Trump Admin. ‘Hurting People’ By Not Sharing Covid-19 Info With Biden | The Last Word">
					<span class="ticker-item-date">November 18, 2020</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Dr. Bhadelia: Trump Admin. ‘Hurting People’ By Not Sharing Covid-19 Info With Biden | The Last Word</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/family-reunited-with-dog-missing-since-january/" title="Family reunited with dog missing since January">
					<span class="ticker-item-date">November 18, 2020</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Family reunited with dog missing since January</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/we-need-to-be-prepared-now-to-cyber-threats-canadian-centre-for-cyber-security/" title="&#8220;We need to be prepared now&#8221; to cyber threats: Canadian Centre for Cyber Security">
					<span class="ticker-item-date">November 18, 2020</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">&#8220;We need to be prepared now&#8221; to cyber threats: Canadian Centre for Cyber Security</span>
				</a>
			</li>	</ul>
</div>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="https://www.sakafete.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header>
<div class="mh-section mh-group">
	<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-85324" class="post-85324 post type-post status-publish format-video has-post-thumbnail hentry category-the-top-news-today tag-american-attorney tag-amy-jean-klobuchar tag-amy-klobuchar tag-ari-melber tag-best-of-last-night tag-chris-krebs tag-christopher-c-krebs tag-current-events tag-donald-trump tag-elections tag-emmy tag-emmy-winning-executive-producer tag-homeland-security tag-infrastructure-security-agency tag-last-word tag-lawrence-odonnell tag-lawrence-odonnell-live tag-liberal-news tag-msnbc tag-msnbc-live tag-msnbc-news tag-news tag-nicolle-wallace tag-online-visit tag-president-trump-fired tag-progressive-news tag-senate-finance-committee tag-the-last-word tag-the-last-word-with-lawrence-odonnell tag-the-rachel-maddow-show tag-united-states-department tag-united-states-senator tag-us-news tag-white-house post_format-post-format-video">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC		</h1><div class="entry-tags clearfix"><span>TOPICS:</span><a href="https://www.sakafete.com/tag/american-attorney/" rel="tag">American attorney</a><a href="https://www.sakafete.com/tag/amy-jean-klobuchar/" rel="tag">Amy Jean Klobuchar</a><a href="https://www.sakafete.com/tag/amy-klobuchar/" rel="tag">Amy Klobuchar</a><a href="https://www.sakafete.com/tag/ari-melber/" rel="tag">Ari Melber</a><a href="https://www.sakafete.com/tag/best-of-last-night/" rel="tag">Best of last night</a><a href="https://www.sakafete.com/tag/chris-krebs/" rel="tag">Chris Krebs</a><a href="https://www.sakafete.com/tag/christopher-c-krebs/" rel="tag">Christopher C. Krebs</a><a href="https://www.sakafete.com/tag/current-events/" rel="tag">current events</a><a href="https://www.sakafete.com/tag/donald-trump/" rel="tag">donald trump</a><a href="https://www.sakafete.com/tag/elections/" rel="tag">elections</a><a href="https://www.sakafete.com/tag/emmy/" rel="tag">Emmy</a><a href="https://www.sakafete.com/tag/emmy-winning-executive-producer/" rel="tag">Emmy-winning executive producer</a><a href="https://www.sakafete.com/tag/homeland-security/" rel="tag">Homeland Security</a><a href="https://www.sakafete.com/tag/infrastructure-security-agency/" rel="tag">Infrastructure Security Agency</a><a href="https://www.sakafete.com/tag/last-word/" rel="tag">Last Word</a><a href="https://www.sakafete.com/tag/lawrence-odonnell/" rel="tag">Lawrence O'Donnell</a><a href="https://www.sakafete.com/tag/lawrence-odonnell-live/" rel="tag">lawrence odonnell live</a><a href="https://www.sakafete.com/tag/liberal-news/" rel="tag">Liberal News</a><a href="https://www.sakafete.com/tag/msnbc/" rel="tag">MSNBC</a><a href="https://www.sakafete.com/tag/msnbc-live/" rel="tag">MSNBC Live</a><a href="https://www.sakafete.com/tag/msnbc-news/" rel="tag">MSNBC News</a><a href="https://www.sakafete.com/tag/news/" rel="tag">news</a><a href="https://www.sakafete.com/tag/nicolle-wallace/" rel="tag">Nicolle Wallace</a><a href="https://www.sakafete.com/tag/online-visit/" rel="tag">Online Visit</a><a href="https://www.sakafete.com/tag/president-trump-fired/" rel="tag">President Trump fired</a><a href="https://www.sakafete.com/tag/progressive-news/" rel="tag">Progressive News</a><a href="https://www.sakafete.com/tag/senate-finance-committee/" rel="tag">Senate Finance Committee</a><a href="https://www.sakafete.com/tag/the-last-word/" rel="tag">The Last Word</a><a href="https://www.sakafete.com/tag/the-last-word-with-lawrence-odonnell/" rel="tag">The Last Word with Lawrence O'Donnell</a><a href="https://www.sakafete.com/tag/the-rachel-maddow-show/" rel="tag">The Rachel Maddow Show</a><a href="https://www.sakafete.com/tag/united-states-department/" rel="tag">United States Department</a><a href="https://www.sakafete.com/tag/united-states-senator/" rel="tag">United States Senator</a><a href="https://www.sakafete.com/tag/us-news/" rel="tag">us news</a><a href="https://www.sakafete.com/tag/white-house/" rel="tag">White House</a></div>	</header>
<div class="entry-thumbnail">
<img width="777" height="437" src="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-777x437.jpg" class="attachment-content-single size-content-single wp-post-image" alt="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC 1" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251.jpg 1280w" sizes="(max-width: 777px) 100vw, 777px" title="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC 1"></div>
<div id="custom_html-7" class="widget_text sb-widget post-ad post-ad-1 widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><p class="entry-meta">
<span class="entry-meta-date updated">November 18, 2020</span>
</p>
	<div class="entry-content clearfix">
		<p>    <span class="ytg-video-container"            style="max-height: 360px"    >          <iframe class="ytg-video-player"    allowfullscreen      src="//www.youtube.com/embed/bvrgkVTcgH8?autoplay=0&amp;rel=1&amp;iv_load_policy=1"  ></iframe>    </span>  </p>
<p>&nbsp;</p>
<p>Sen. Amy Klobuchar reacts to the breaking news that President Trump fired our nation’s top cyber security expert via tweet. Sen. Klobuchar stresses Chris Krebs’ job went well beyond election security as Trump is really putting the nation at risk for his personal grievance against the man who said this was the most secure U.S. election ever. Aired on 11/17/2020.<br />
» Subscribe to MSNBC: </p>
<p>About The Last Word with Lawrence O&#039;Donnell:<br />
Drawing upon his experience as a former chief of staff on the Senate Finance Committee and as an Emmy-winning executive producer and writer of &quot;&quot;The West Wing,&quot;&quot; Lawrence O&#039;Donnell examines the compelling and impactful political stories of the day. O&#039;Donnell convenes diverse panels of guests, including a variety of politicians and cultural voices, to offer unique viewpoints and perspective. In his signature style, O&#039;Donnell highlights the latest news developments and offers his take on the political stories driving the national conversation.</p>
<p>MSNBC delivers breaking news, in-depth analysis of politics headlines, as well as commentary and informed perspectives. Find video clips and segments from The Rachel Maddow Show, Morning Joe, Meet the Press Daily, The Beat with Ari Melber, Deadline: White House with Nicolle Wallace, Hardball, All In, Last Word, 11th Hour, and more.</p>
<p>Connect with MSNBC Online<br />
Visit msnbc.com:<br />
Subscribe to MSNBC Newsletter:<br />
Find MSNBC on Facebook:<br />
Follow MSNBC on Twitter:<br />
Follow MSNBC on Instagram: </p>
<p>#AmyKlobuchar #PresidentTrump #MSNBC</p>
<p>Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC</p>
<div class="ytg-video-url">
<p><iframe title="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC" width="777" height="437" src="https://www.youtube.com/embed/bvrgkVTcgH8?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
	</div>
	<div id="custom_html-8" class="widget_text sb-widget post-ad post-ad-2 widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div></article><div class="mh-share-buttons mh-group">
    <a class="mh-col mh-1-4 mh-facebook" href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/&t=Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
	    <span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span>
	</a>
    <a class="mh-col mh-1-4 mh-twitter" href="#" onclick="window.open('http://twitter.com/share?text=Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC -&url=https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
	    <span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span>
	</a>
    <a class="mh-col mh-1-4 mh-pinterest" href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/&media=https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-1251.jpg&description=Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
	    <span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span>
	</a>
    <a class="mh-col mh-1-4 mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
	    <span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span>
	</a>
</div><nav class="post-nav-wrap" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="https://www.sakafete.com/dr-bhadelia-trump-admin-hurting-people-by-not-sharing-covid-19-info-with-biden-the-last-word/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
<li class="post-nav-next">
<a href="https://www.sakafete.com/lawrence-another-day-another-trump-vengeance-firing-the-last-word-msnbc/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li>
</ul>
</nav>
		<h4 class="widget-title related-content-title">
			<span>Related Articles</span>
		</h4>
		<div class="related-content clearfix"><article class="mh-col mh-1-4 content-grid post-79525 post type-post status-publish format-video has-post-thumbnail hentry category-the-top-news-today tag-ari-melber tag-assessment-of-mood tag-best-of-last-night tag-best-of-rachel-maddow tag-breaking-news tag-coopting-courts tag-courts tag-current-events tag-democratic-backlash tag-democrats tag-donald-trump tag-elections tag-energy-of-democrats tag-federal-court-system tag-instagram tag-maddow tag-maddow-live tag-mitch-mcconnell tag-mitch-mcconnell-supreme-court tag-msnbc tag-msnbc-live tag-msnbc-news tag-msnbc-tv tag-msnbc-com tag-news tag-nicolle-wallace tag-online-visit tag-political-news tag-politics tag-politics-news tag-rachel-maddow tag-rachel-maddow-msnbc tag-rachel-maddow-show tag-the-rachel-maddow-show tag-trms tag-twitter tag-us-news tag-white-house post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/maddow-on-the-building-democratic-backlash-to-mcconnell-coopting-courts-rachel-maddow/" title="Maddow On The Building Democratic Backlash To McConnell Coopting Courts | Rachel Maddow"><picture class="attachment-content-grid size-content-grid wp-post-image" loading="lazy" title="Maddow On The Building Democratic Backlash To McConnell Coopting Courts | Rachel Maddow 2">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620.jpg.webp 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
<img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-180x101.jpg" alt="Maddow On The Building Democratic Backlash To McConnell Coopting Courts | Rachel Maddow 2" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1620.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
</picture>
		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/maddow-on-the-building-democratic-backlash-to-mcconnell-coopting-courts-rachel-maddow/" title="Maddow On The Building Democratic Backlash To McConnell Coopting Courts | Rachel Maddow" rel="bookmark">
			Maddow On The Building Democratic Backlash To McConnell Coopting Courts | Rachel Maddow		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-7455 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz tag-1932 tag-donald-trump tag-donald-trump-10516 tag-donald-trump-nevada tag-donald-trump-rally tag-donald-trump-speech tag-donald-trump-speech-2016 tag-donald-tump-henderson-nv tag-henderson-nv tag-nevada tag-october-5-2016 tag-trump-2016 tag-trump-campaign-rally tag-trump-henderson-nevada tag-trump-rally tag-trump-rally-henderson tag-trump-rally-nevada tag-trump-speech tag-trump-speech-2016 post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/donald-trump-speech-10516-henderson-nevada-rally/" title="Donald Trump Speech 10/5/16: Henderson, Nevada Rally"><img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18.jpg" class="attachment-content-grid size-content-grid wp-post-image" alt="Donald Trump Speech 10/5/16: Henderson, Nevada Rally 3" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18.jpg 1280w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-153x86.jpg 153w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-170x96.jpg 170w, https://www.sakafete.com/wp-content/uploads/2016/10/maxresdefault-18-50x28.jpg 50w" sizes="(max-width: 180px) 100vw, 180px" title="Donald Trump Speech 10/5/16: Henderson, Nevada Rally 3">		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/donald-trump-speech-10516-henderson-nevada-rally/" title="Donald Trump Speech 10/5/16: Henderson, Nevada Rally" rel="bookmark">
			Donald Trump Speech 10/5/16: Henderson, Nevada Rally		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-33934 post type-post status-publish format-video has-post-thumbnail hentry category-the-top-news-today tag-ari-melber tag-ari-melber-live tag-ari-melber-msnbc tag-breaking-news tag-business tag-congress tag-current-events tag-democrats-impeachment tag-donald-trump tag-health tag-house tag-house-judiciary-committee tag-impeach-donald-trump tag-impeach-trump tag-impeachment tag-impeachment-inquiry tag-liberal tag-msnbc tag-msnbc-live tag-nadler tag-nbc-news tag-politics tag-pop-culture tag-progressive tag-senate tag-supreme-court tag-the-beat-with-ari-melber tag-top-stories tag-trump tag-trump-impeachment tag-trump-impeachment-inquiry tag-ukraine tag-us-news tag-white-house tag-world-news post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/disaster-trump-may-face-his-nightmare-impeachment-trial-with-john-roberts-in-charge-msnbc/" title="‘Disaster’: Trump May Face His Nightmare Impeachment Trial With John Roberts In Charge | MSNBC"><img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-180x101.jpg" class="attachment-content-grid size-content-grid wp-post-image" alt="‘Disaster’: Trump May Face His Nightmare Impeachment Trial With John Roberts In Charge | MSNBC 4" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-402.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px" title="‘Disaster’: Trump May Face His Nightmare Impeachment Trial With John Roberts In Charge | MSNBC 4">		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/disaster-trump-may-face-his-nightmare-impeachment-trial-with-john-roberts-in-charge-msnbc/" title="‘Disaster’: Trump May Face His Nightmare Impeachment Trial With John Roberts In Charge | MSNBC" rel="bookmark">
			‘Disaster’: Trump May Face His Nightmare Impeachment Trial With John Roberts In Charge | MSNBC		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-32917 post type-post status-publish format-video has-post-thumbnail hentry category-the-top-news-today tag-america tag-anwar-gargash tag-ayatollah-ali-khamenei tag-bagdad tag-canada tag-canadian-politics tag-ctv tag-ctv-news tag-donald-trump tag-drone-strike tag-esmail-ghaani tag-evan-solomon tag-gen-qassem-soleimani tag-harjit-sajjan tag-hassan-nasrallah tag-hezbollah tag-iran tag-iraq tag-john-bolton tag-khamenei tag-mark-esper tag-naftali-bennett tag-news tag-politics tag-power-play tag-qassem-soleimani tag-qud tag-revolutionary-guard tag-soleimani tag-tehran tag-trump tag-u-s tag-usa tag-26394 tag-26393 tag-26392 post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/canada-was-not-informed-of-u-s-drone-strike-that-killed-iranian-general-soleimani-sajjan/" title="Canada was not informed of U.S. drone strike that killed Iranian general Soleimani: Sajjan"><img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-180x101.jpg" class="attachment-content-grid size-content-grid wp-post-image" alt="Canada was not informed of U.S. drone strike that killed Iranian general Soleimani: Sajjan 5" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-117.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px" title="Canada was not informed of U.S. drone strike that killed Iranian general Soleimani: Sajjan 5">		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/canada-was-not-informed-of-u-s-drone-strike-that-killed-iranian-general-soleimani-sajjan/" title="Canada was not informed of U.S. drone strike that killed Iranian general Soleimani: Sajjan" rel="bookmark">
			Canada was not informed of U.S. drone strike that killed Iranian general Soleimani: Sajjan		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator">		</div>		<div class="comments-wrap">
			<h4 class="comment-section-title">
				<span class="comment-count">62 Comments</span> <span class="comment-count-more">on "Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC"</span>			</h4>
			<ol class="commentlist">
						<li class="comment even thread-even depth-1" id="li-comment-1233270">
			<div id="comment-1233270">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">thad dunkin</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233270">November 18, 2020 at 12:52 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233270' data-commentid="1233270" data-postid="85324" data-belowelement="comment-1233270" data-respondelement="respond" data-replyto="Reply to thad dunkin" aria-label='Reply to thad dunkin'>Reply</a>														</div>
								<div class="comment-text">
					<p>The fact that he does this without push-back tells the bigger story, nobody cares anymore.</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233273">
			<div id="comment-1233273">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">DARK CENTURIANS</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233273">November 18, 2020 at 1:15 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233273' data-commentid="1233273" data-postid="85324" data-belowelement="comment-1233273" data-respondelement="respond" data-replyto="Reply to DARK CENTURIANS" aria-label='Reply to DARK CENTURIANS'>Reply</a>														</div>
								<div class="comment-text">
					<p>I think everyone who was fired by trump already knew they were going to be fired. Almost like it’s expected of Trump to act this way.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233272">
			<div id="comment-1233272">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Dana Ball</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233272">November 18, 2020 at 1:28 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233272' data-commentid="1233272" data-postid="85324" data-belowelement="comment-1233272" data-respondelement="respond" data-replyto="Reply to Dana Ball" aria-label='Reply to Dana Ball'>Reply</a>														</div>
								<div class="comment-text">
					<p>Biden can hire him back.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233271">
			<div id="comment-1233271">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Cecilia Bond</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233271">November 18, 2020 at 1:29 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233271' data-commentid="1233271" data-postid="85324" data-belowelement="comment-1233271" data-respondelement="respond" data-replyto="Reply to Cecilia Bond" aria-label='Reply to Cecilia Bond'>Reply</a>														</div>
								<div class="comment-text">
					<p>By nobody you mean Repugatards!</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1" id="li-comment-1233261">
			<div id="comment-1233261">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">The Ghost</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233261">November 18, 2020 at 12:53 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233261' data-commentid="1233261" data-postid="85324" data-belowelement="comment-1233261" data-respondelement="respond" data-replyto="Reply to The Ghost" aria-label='Reply to The Ghost'>Reply</a>														</div>
								<div class="comment-text">
					<p>Donald Trump is more Dangerous than Covid 19,<br />
He must be removed from office now.</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233266">
			<div id="comment-1233266">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Mark Keyser</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233266">November 18, 2020 at 1:37 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233266' data-commentid="1233266" data-postid="85324" data-belowelement="comment-1233266" data-respondelement="respond" data-replyto="Reply to Mark Keyser" aria-label='Reply to Mark Keyser'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Dana Ball Don&#8217;t rile him ma&#8217;am, he may be a Proud Boy.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233265">
			<div id="comment-1233265">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Dana Ball</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233265">November 18, 2020 at 1:42 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233265' data-commentid="1233265" data-postid="85324" data-belowelement="comment-1233265" data-respondelement="respond" data-replyto="Reply to Dana Ball" aria-label='Reply to Dana Ball'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Mark Keyser I&#8217;m a dude, not a ma&#8217;am.  Common mistake.  Proud Boys must have loved seeing Trump dance to YMCA, and hear him say that he wanted to kiss all the men in the front row.  Oh my!  LOL</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233264">
			<div id="comment-1233264">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Dana Ball</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233264">November 18, 2020 at 1:44 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233264' data-commentid="1233264" data-postid="85324" data-belowelement="comment-1233264" data-respondelement="respond" data-replyto="Reply to Dana Ball" aria-label='Reply to Dana Ball'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Cecilia Bond  Making fun of Trumpists involves simply pointing out the truth.  😀🇺🇸🗽</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233263">
			<div id="comment-1233263">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">for paws</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233263">November 18, 2020 at 7:28 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233263' data-commentid="1233263" data-postid="85324" data-belowelement="comment-1233263" data-respondelement="respond" data-replyto="Reply to for paws" aria-label='Reply to for paws'>Reply</a>														</div>
								<div class="comment-text">
					<p>Back to the SWUMP at Mara Go Go</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233262">
			<div id="comment-1233262">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronnie Mead</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233262">November 18, 2020 at 12:41 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233262' data-commentid="1233262" data-postid="85324" data-belowelement="comment-1233262" data-respondelement="respond" data-replyto="Reply to Ronnie Mead" aria-label='Reply to Ronnie Mead'>Reply</a>														</div>
								<div class="comment-text">
					<p>Or at the very least be CONTAINED.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233267">
			<div id="comment-1233267">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Victoria Warrior</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233267">November 18, 2020 at 12:54 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233267' data-commentid="1233267" data-postid="85324" data-belowelement="comment-1233267" data-respondelement="respond" data-replyto="Reply to Victoria Warrior" aria-label='Reply to Victoria Warrior'>Reply</a>														</div>
								<div class="comment-text">
					<p>When is trump going to be removed for his attempt to destroy America those who support him are responsible for the fate of our country</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233269">
			<div id="comment-1233269">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">GH1618</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233269">November 18, 2020 at 1:23 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233269' data-commentid="1233269" data-postid="85324" data-belowelement="comment-1233269" data-respondelement="respond" data-replyto="Reply to GH1618" aria-label='Reply to GH1618'>Reply</a>														</div>
								<div class="comment-text">
					<p>When VP Pence puts the nation first, concedes the election, and procedes to invoke the 25th Amendment.  But don’t hold your breath.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233268">
			<div id="comment-1233268">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Nota Bene</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233268">November 18, 2020 at 3:42 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233268' data-commentid="1233268" data-postid="85324" data-belowelement="comment-1233268" data-respondelement="respond" data-replyto="Reply to Nota Bene" aria-label='Reply to Nota Bene'>Reply</a>														</div>
								<div class="comment-text">
					<p>Adolf Schicklgruber also eliminated his Krebs on his last days at the Führerbunker.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1233236">
			<div id="comment-1233236">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Tweetie-Louise</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233236">November 18, 2020 at 12:58 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233236' data-commentid="1233236" data-postid="85324" data-belowelement="comment-1233236" data-respondelement="respond" data-replyto="Reply to Tweetie-Louise" aria-label='Reply to Tweetie-Louise'>Reply</a>														</div>
								<div class="comment-text">
					<p>Fired for telling the truth and not endorsing the perfidious candidate 🤦‍♀️</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233274">
			<div id="comment-1233274">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">John Hughes</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233274">November 18, 2020 at 1:07 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233274' data-commentid="1233274" data-postid="85324" data-belowelement="comment-1233274" data-respondelement="respond" data-replyto="Reply to John Hughes" aria-label='Reply to John Hughes'>Reply</a>														</div>
								<div class="comment-text">
					<p>Maybe Biden should hire him and get all the security info he needs???</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233276">
			<div id="comment-1233276">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">GH1618</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233276">November 18, 2020 at 1:25 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233276' data-commentid="1233276" data-postid="85324" data-belowelement="comment-1233276" data-respondelement="respond" data-replyto="Reply to GH1618" aria-label='Reply to GH1618'>Reply</a>														</div>
								<div class="comment-text">
					<p>He can’t give classified information to Biden or anyone else.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233275">
			<div id="comment-1233275">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Cecilia Bond</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233275">November 18, 2020 at 1:41 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233275' data-commentid="1233275" data-postid="85324" data-belowelement="comment-1233275" data-respondelement="respond" data-replyto="Reply to Cecilia Bond" aria-label='Reply to Cecilia Bond'>Reply</a>														</div>
								<div class="comment-text">
					<p>@GH1618 Not to sure that&#8217;s true, if it is the incoming President.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1233255">
			<div id="comment-1233255">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">TheChiefEng</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233255">November 18, 2020 at 1:11 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233255' data-commentid="1233255" data-postid="85324" data-belowelement="comment-1233255" data-respondelement="respond" data-replyto="Reply to TheChiefEng" aria-label='Reply to TheChiefEng'>Reply</a>														</div>
								<div class="comment-text">
					<p>If you are a competent person of honor and integrity, you will always be an enemy in the eyes of Donald Trump.</p>
				</div>
			</div><ul class="children">
		<li class="comment even depth-2" id="li-comment-1233259">
			<div id="comment-1233259">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Dana Ball</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233259">November 18, 2020 at 1:34 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233259' data-commentid="1233259" data-postid="85324" data-belowelement="comment-1233259" data-respondelement="respond" data-replyto="Reply to Dana Ball" aria-label='Reply to Dana Ball'>Reply</a>														</div>
								<div class="comment-text">
					<p>Amen to that.  It&#8217;s the same way with all totalitarian regimes.  Trump acts like a dictator.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233258">
			<div id="comment-1233258">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Alvinius Alviniathan</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233258">November 18, 2020 at 3:15 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233258' data-commentid="1233258" data-postid="85324" data-belowelement="comment-1233258" data-respondelement="respond" data-replyto="Reply to Alvinius Alviniathan" aria-label='Reply to Alvinius Alviniathan'>Reply</a>														</div>
								<div class="comment-text">
					<p>And if you are a fraud, crony, or bootlicker, you are great in the eyes of Donald trump.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233257">
			<div id="comment-1233257">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">David Pitts</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233257">November 18, 2020 at 3:42 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233257' data-commentid="1233257" data-postid="85324" data-belowelement="comment-1233257" data-respondelement="respond" data-replyto="Reply to David Pitts" aria-label='Reply to David Pitts'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Alvinius Alviniathan Amen to that sibling!</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233256">
			<div id="comment-1233256">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Timothy McGuire</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233256">November 18, 2020 at 10:56 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233256' data-commentid="1233256" data-postid="85324" data-belowelement="comment-1233256" data-respondelement="respond" data-replyto="Reply to Timothy McGuire" aria-label='Reply to Timothy McGuire'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Dana Ball the truth is always the enemy of dictators &#038; wannabe dictators like the one who is squatting in our White House</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233225">
			<div id="comment-1233225">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Joe Fitz</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233225">November 18, 2020 at 1:13 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233225' data-commentid="1233225" data-postid="85324" data-belowelement="comment-1233225" data-respondelement="respond" data-replyto="Reply to Joe Fitz" aria-label='Reply to Joe Fitz'>Reply</a>														</div>
								<div class="comment-text">
					<p>Trump is definitely playing the victim, whilst he’s hiding away and blaming everyone else for his mistakes</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233229">
			<div id="comment-1233229">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Alvinius Alviniathan</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233229">November 18, 2020 at 3:12 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233229' data-commentid="1233229" data-postid="85324" data-belowelement="comment-1233229" data-respondelement="respond" data-replyto="Reply to Alvinius Alviniathan" aria-label='Reply to Alvinius Alviniathan'>Reply</a>														</div>
								<div class="comment-text">
					<p>Joe Fitz the man is a delusional sociopath&#8230; There is something definitely wrong with him.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233228">
			<div id="comment-1233228">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Linda g</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233228">November 18, 2020 at 2:36 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233228' data-commentid="1233228" data-postid="85324" data-belowelement="comment-1233228" data-respondelement="respond" data-replyto="Reply to Linda g" aria-label='Reply to Linda g'>Reply</a>														</div>
								<div class="comment-text">
					<p>The only crime that Krebs committed was telling the truth.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233227">
			<div id="comment-1233227">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronny Eriksson</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233227">November 18, 2020 at 2:45 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233227' data-commentid="1233227" data-postid="85324" data-belowelement="comment-1233227" data-respondelement="respond" data-replyto="Reply to Ronny Eriksson" aria-label='Reply to Ronny Eriksson'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Linda g But that seem to be a crime in Tumps USA.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233226">
			<div id="comment-1233226">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Linda g</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233226">November 18, 2020 at 5:26 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233226' data-commentid="1233226" data-postid="85324" data-belowelement="comment-1233226" data-respondelement="respond" data-replyto="Reply to Linda g" aria-label='Reply to Linda g'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Ronny Eriksson Sad but true.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1233230">
			<div id="comment-1233230">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">nathar40</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233230">November 18, 2020 at 1:17 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233230' data-commentid="1233230" data-postid="85324" data-belowelement="comment-1233230" data-respondelement="respond" data-replyto="Reply to nathar40" aria-label='Reply to nathar40'>Reply</a>														</div>
								<div class="comment-text">
					<p>Trump is taking the ship down with him. They should have never let this fool be President.</p>
				</div>
			</div><ul class="children">
		<li class="comment even depth-2" id="li-comment-1233235">
			<div id="comment-1233235">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">The Spaz</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233235">November 18, 2020 at 5:56 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233235' data-commentid="1233235" data-postid="85324" data-belowelement="comment-1233235" data-respondelement="respond" data-replyto="Reply to The Spaz" aria-label='Reply to The Spaz'>Reply</a>														</div>
								<div class="comment-text">
					<p>Blood is on all our hands, weather you voted or not&#8230; unfortunately&#8230;</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233234">
			<div id="comment-1233234">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Greg Miller</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233234">November 18, 2020 at 7:51 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233234' data-commentid="1233234" data-postid="85324" data-belowelement="comment-1233234" data-respondelement="respond" data-replyto="Reply to Greg Miller" aria-label='Reply to Greg Miller'>Reply</a>														</div>
								<div class="comment-text">
					<p>no truer words were ever spoken&#8230;</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233233">
			<div id="comment-1233233">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">MClovin 2020</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233233">November 18, 2020 at 8:58 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233233' data-commentid="1233233" data-postid="85324" data-belowelement="comment-1233233" data-respondelement="respond" data-replyto="Reply to MClovin 2020" aria-label='Reply to MClovin 2020'>Reply</a>														</div>
								<div class="comment-text">
					<p>#Facts</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233232">
			<div id="comment-1233232">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Quarky Chick</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233232">November 18, 2020 at 11:33 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233232' data-commentid="1233232" data-postid="85324" data-belowelement="comment-1233232" data-respondelement="respond" data-replyto="Reply to Quarky Chick" aria-label='Reply to Quarky Chick'>Reply</a>														</div>
								<div class="comment-text">
					<p>@The Spaz Nope. I never supported, or voted for, that corrupt disgusting man, nor would I. Speak for yourself.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233231">
			<div id="comment-1233231">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">The Spaz</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233231">November 18, 2020 at 4:48 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233231' data-commentid="1233231" data-postid="85324" data-belowelement="comment-1233231" data-respondelement="respond" data-replyto="Reply to The Spaz" aria-label='Reply to The Spaz'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Quarky Chick Neither have I but that doesn&#8217;t absolve us from anything. We are at a point where we just can&#8217;t opt out without repercussions. There is no magical third door that will transport you temporarily into a state of entropy. But its not entirely our fault either, we are stuck in a rock and a hard place and Trump is merely a symptom to a greater cause. This doesn&#8217;t end with him&#8230; Point is we have all these philosophies about responsibility and accountability within the shades of grey yet when it comes down to it we still think in black and white. All we have done is point fingers at others just to pretend ours are clean and hence we are still being held at gun point by this virus. It doesn&#8217;t split hairs between the left, right, ALM, BLM, LBQT ,KKK , Proud Boys, MAGA  etc. None of it matters because its just one of the many sides of a multifaceted die and we are not making a very good case for it to not pull the trigger. The future of our species is in question (this issue is not just in the US. India, China, Russia are all having their version of internal power struggles) and it will likely not end here but the wound from the bullet will shape the length of our path till the wound festers and we as a country succumb. </p>
<p>Its ironic, but it does feel like we are reliving those superhero movies just without the capes, superpowers and heroes. We are having our own existential crisis and we are heading into Civil War. Eventually we will be having our own Infinity War and End Game. The only difference is that there is no time traveling to stop Thanos (Trump) and stopping Thanos (Trump) isn&#8217;t automatically a happy ending. But we are still in the middle of our own version of Civil War.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-even depth-1" id="li-comment-1233244">
			<div id="comment-1233244">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Code Zero</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233244">November 18, 2020 at 1:20 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233244' data-commentid="1233244" data-postid="85324" data-belowelement="comment-1233244" data-respondelement="respond" data-replyto="Reply to Code Zero" aria-label='Reply to Code Zero'>Reply</a>														</div>
								<div class="comment-text">
					<p>Okay, whenever Trump said ” they&#8217;re good people” it’s more like they are people who are loyal to him.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1" id="li-comment-1233245">
			<div id="comment-1233245">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">tecums3h</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233245">November 18, 2020 at 1:26 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233245' data-commentid="1233245" data-postid="85324" data-belowelement="comment-1233245" data-respondelement="respond" data-replyto="Reply to tecums3h" aria-label='Reply to tecums3h'>Reply</a>														</div>
								<div class="comment-text">
					<p>Trump has been fired. Bye, bye.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt thread-even depth-1" id="li-comment-1233246">
			<div id="comment-1233246">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">omi god</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233246">November 18, 2020 at 1:29 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233246' data-commentid="1233246" data-postid="85324" data-belowelement="comment-1233246" data-respondelement="respond" data-replyto="Reply to omi god" aria-label='Reply to omi god'>Reply</a>														</div>
								<div class="comment-text">
					<p>*Trump keeps acting like he thinks he can just ignore the election.*</p>
				</div>
			</div><ul class="children">
		<li class="comment even depth-2" id="li-comment-1233248">
			<div id="comment-1233248">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Daniel Ryslink</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233248">November 18, 2020 at 5:28 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233248' data-commentid="1233248" data-postid="85324" data-belowelement="comment-1233248" data-respondelement="respond" data-replyto="Reply to Daniel Ryslink" aria-label='Reply to Daniel Ryslink'>Reply</a>														</div>
								<div class="comment-text">
					<p>He obviously can, so far.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233247">
			<div id="comment-1233247">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronnie Mead</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233247">November 18, 2020 at 12:39 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233247' data-commentid="1233247" data-postid="85324" data-belowelement="comment-1233247" data-respondelement="respond" data-replyto="Reply to Ronnie Mead" aria-label='Reply to Ronnie Mead'>Reply</a>														</div>
								<div class="comment-text">
					<p>Cant wait for him to be dragged out of the WH by his wig with him screaming and yelling I WON I WON I WON.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1" id="li-comment-1233277">
			<div id="comment-1233277">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Cut Twice</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233277">November 18, 2020 at 1:30 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233277' data-commentid="1233277" data-postid="85324" data-belowelement="comment-1233277" data-respondelement="respond" data-replyto="Reply to Cut Twice" aria-label='Reply to Cut Twice'>Reply</a>														</div>
								<div class="comment-text">
					<p>Krebs is an honorable man. Biden should hire him, least difficult transition for a department.</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233279">
			<div id="comment-1233279">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Bill Confidential</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233279">November 18, 2020 at 6:53 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233279' data-commentid="1233279" data-postid="85324" data-belowelement="comment-1233279" data-respondelement="respond" data-replyto="Reply to Bill Confidential" aria-label='Reply to Bill Confidential'>Reply</a>														</div>
								<div class="comment-text">
					<p>Very good point</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233278">
			<div id="comment-1233278">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronnie Mead</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233278">November 18, 2020 at 12:41 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233278' data-commentid="1233278" data-postid="85324" data-belowelement="comment-1233278" data-respondelement="respond" data-replyto="Reply to Ronnie Mead" aria-label='Reply to Ronnie Mead'>Reply</a>														</div>
								<div class="comment-text">
					<p>AMEM.  I am sure they will not let such talent go to waste.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-even depth-1" id="li-comment-1233253">
			<div id="comment-1233253">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">adscri</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233253">November 18, 2020 at 2:09 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233253' data-commentid="1233253" data-postid="85324" data-belowelement="comment-1233253" data-respondelement="respond" data-replyto="Reply to adscri" aria-label='Reply to adscri'>Reply</a>														</div>
								<div class="comment-text">
					<p>Trump evidently made a big mistake &#8211; he appointed an honest person.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1" id="li-comment-1233219">
			<div id="comment-1233219">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">willow881000</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233219">November 18, 2020 at 2:12 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233219' data-commentid="1233219" data-postid="85324" data-belowelement="comment-1233219" data-respondelement="respond" data-replyto="Reply to willow881000" aria-label='Reply to willow881000'>Reply</a>														</div>
								<div class="comment-text">
					<p>Donald Trump is the worst thing that happened to America. EVER!!!</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233224">
			<div id="comment-1233224">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Alvinius Alviniathan</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233224">November 18, 2020 at 3:17 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233224' data-commentid="1233224" data-postid="85324" data-belowelement="comment-1233224" data-respondelement="respond" data-replyto="Reply to Alvinius Alviniathan" aria-label='Reply to Alvinius Alviniathan'>Reply</a>														</div>
								<div class="comment-text">
					<p>willow881000 for sure.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233223">
			<div id="comment-1233223">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Mercator Jubio</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233223">November 18, 2020 at 7:48 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233223' data-commentid="1233223" data-postid="85324" data-belowelement="comment-1233223" data-respondelement="respond" data-replyto="Reply to Mercator Jubio" aria-label='Reply to Mercator Jubio'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Ian G not for long, he is.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233222">
			<div id="comment-1233222">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Kevin Brown</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233222">November 18, 2020 at 8:39 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233222' data-commentid="1233222" data-postid="85324" data-belowelement="comment-1233222" data-respondelement="respond" data-replyto="Reply to Kevin Brown" aria-label='Reply to Kevin Brown'>Reply</a>														</div>
								<div class="comment-text">
					<p>No he isn&#8217;t. Anyone with the legal ability to remove him, but choose not to ,are worse.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233221">
			<div id="comment-1233221">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Harris Biden 2020 WON !!!</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233221">November 18, 2020 at 12:35 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233221' data-commentid="1233221" data-postid="85324" data-belowelement="comment-1233221" data-respondelement="respond" data-replyto="Reply to Harris Biden 2020 WON !!!" aria-label='Reply to Harris Biden 2020 WON !!!'>Reply</a>														</div>
								<div class="comment-text">
					<p>Pro covid19 Trump GOP and republicans and Senate- “ America does not need PPP it needs Amy barret! “ The Senate decided to nominate a corrupt supreme court judge instead of giving America PPP and then they decided to go on vacation until next year leaving America out in the cold 🥶 to fight covid19 by ourselves, Georgia you’re the only hope to save America please vote for the Democrats so America can survive the trump virus 🦠</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233220">
			<div id="comment-1233220">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronnie Mead</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233220">November 18, 2020 at 12:38 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233220' data-commentid="1233220" data-postid="85324" data-belowelement="comment-1233220" data-respondelement="respond" data-replyto="Reply to Ronnie Mead" aria-label='Reply to Ronnie Mead'>Reply</a>														</div>
								<div class="comment-text">
					<p>The absolute worst of the worst.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233237">
			<div id="comment-1233237">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">DIVIDED AMERICA</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233237">November 18, 2020 at 2:13 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233237' data-commentid="1233237" data-postid="85324" data-belowelement="comment-1233237" data-respondelement="respond" data-replyto="Reply to DIVIDED AMERICA" aria-label='Reply to DIVIDED AMERICA'>Reply</a>														</div>
								<div class="comment-text">
					<p>Anyone supporting Trump now is 100% anti-American. Zero doubt about that.</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233242">
			<div id="comment-1233242">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Quarky Chick</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233242">November 18, 2020 at 11:35 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233242' data-commentid="1233242" data-postid="85324" data-belowelement="comment-1233242" data-respondelement="respond" data-replyto="Reply to Quarky Chick" aria-label='Reply to Quarky Chick'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Vict0r Mas0n Such an ignorant, uninformed tool. Crawl back under your rock, fascist.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233241">
			<div id="comment-1233241">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Jeffrey Whipple</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233241">November 18, 2020 at 11:56 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233241' data-commentid="1233241" data-postid="85324" data-belowelement="comment-1233241" data-respondelement="respond" data-replyto="Reply to Jeffrey Whipple" aria-label='Reply to Jeffrey Whipple'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Vict0r Mas0n You ever get unemployment, Social Security, Medicare, Medicaid, did you cash your stimulus check?  Congrats, you&#8217;re a Socialist Parasite, Moron!</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233240">
			<div id="comment-1233240">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Ronny Eriksson</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233240">November 18, 2020 at 2:49 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233240' data-commentid="1233240" data-postid="85324" data-belowelement="comment-1233240" data-respondelement="respond" data-replyto="Reply to Ronny Eriksson" aria-label='Reply to Ronny Eriksson'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Vict0r Mas0n Should US be a democracy, or should it not? If you want democracy, you have to see that Donald Trump is the greatest treath to it &#8211; ever.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233239">
			<div id="comment-1233239">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Julie Sprik</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233239">November 18, 2020 at 5:46 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233239' data-commentid="1233239" data-postid="85324" data-belowelement="comment-1233239" data-respondelement="respond" data-replyto="Reply to Julie Sprik" aria-label='Reply to Julie Sprik'>Reply</a>														</div>
								<div class="comment-text">
					<p>I couldn&#8217;t agree more,this is outrageous.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233238">
			<div id="comment-1233238">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Julie Sprik</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233238">November 18, 2020 at 5:47 PM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233238' data-commentid="1233238" data-postid="85324" data-belowelement="comment-1233238" data-respondelement="respond" data-replyto="Reply to Julie Sprik" aria-label='Reply to Julie Sprik'>Reply</a>														</div>
								<div class="comment-text">
					<p>@Vict0r Mas0n It&#8217;s: College,genius</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1" id="li-comment-1233249">
			<div id="comment-1233249">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">FortCC</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233249">November 18, 2020 at 2:37 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233249' data-commentid="1233249" data-postid="85324" data-belowelement="comment-1233249" data-respondelement="respond" data-replyto="Reply to FortCC" aria-label='Reply to FortCC'>Reply</a>														</div>
								<div class="comment-text">
					<p>Trump couldn’t fire him in person. That’s what a coward does.</p>
				</div>
			</div><ul class="children">
		<li class="comment odd alt depth-2" id="li-comment-1233252">
			<div id="comment-1233252">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Amanda Woods</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233252">November 18, 2020 at 6:42 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233252' data-commentid="1233252" data-postid="85324" data-belowelement="comment-1233252" data-respondelement="respond" data-replyto="Reply to Amanda Woods" aria-label='Reply to Amanda Woods'>Reply</a>														</div>
								<div class="comment-text">
					<p>Triangulation through Twitter.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even depth-2" id="li-comment-1233251">
			<div id="comment-1233251">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Linda Jackson</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233251">November 18, 2020 at 8:48 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233251' data-commentid="1233251" data-postid="85324" data-belowelement="comment-1233251" data-respondelement="respond" data-replyto="Reply to Linda Jackson" aria-label='Reply to Linda Jackson'>Reply</a>														</div>
								<div class="comment-text">
					<p>Has tRump ever fired anyone in person, other than on his ridiculous Reality TV show.  Probably not. I guess it&#8217;s hard to look a better person than you in the eye and fire them.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt depth-2" id="li-comment-1233250">
			<div id="comment-1233250">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Teresa S</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233250">November 18, 2020 at 9:50 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233250' data-commentid="1233250" data-postid="85324" data-belowelement="comment-1233250" data-respondelement="respond" data-replyto="Reply to Teresa S" aria-label='Reply to Teresa S'>Reply</a>														</div>
								<div class="comment-text">
					<p>It makes Trump feel more powerful to Tweet the firings, especially since his devote cult followers will Tweet back support for his actions.</p>
				</div>
			</div></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233260">
			<div id="comment-1233260">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Puri Jo Garcia</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233260">November 18, 2020 at 3:24 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233260' data-commentid="1233260" data-postid="85324" data-belowelement="comment-1233260" data-respondelement="respond" data-replyto="Reply to Puri Jo Garcia" aria-label='Reply to Puri Jo Garcia'>Reply</a>														</div>
								<div class="comment-text">
					<p>The public should decry tRUMP’s firing of Dir. KREBS, the DHS official who makes sure of our security.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1233254">
			<div id="comment-1233254">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Alicia O.</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233254">November 18, 2020 at 4:29 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233254' data-commentid="1233254" data-postid="85324" data-belowelement="comment-1233254" data-respondelement="respond" data-replyto="Reply to Alicia O." aria-label='Reply to Alicia O.'>Reply</a>														</div>
								<div class="comment-text">
					<p>He has integrity and values honesty being one.  Trump doesn&#8217;t have it.</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="li-comment-1233218">
			<div id="comment-1233218">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">Rod Daniels</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233218">November 18, 2020 at 5:21 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233218' data-commentid="1233218" data-postid="85324" data-belowelement="comment-1233218" data-respondelement="respond" data-replyto="Reply to Rod Daniels" aria-label='Reply to Rod Daniels'>Reply</a>														</div>
								<div class="comment-text">
					<p>Only a psychopath will fire a person who did his job too well. The guy is a hero (winner!!) and Trump is a coward (loser!!)</p>
				</div>
			</div></li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1233243">
			<div id="comment-1233243">
				<div class="vcard meta">
					<img alt='' src='https://secure.gravatar.com/avatar/?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo avatar-default' height='70' width='70' loading='lazy'/>					<span class="fn">eduardo quirino</span> |
					<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#comment-1233243">November 18, 2020 at 6:08 AM</a> |
											<a rel='nofollow' class='comment-reply-link' href='#comment-1233243' data-commentid="1233243" data-postid="85324" data-belowelement="comment-1233243" data-respondelement="respond" data-replyto="Reply to eduardo quirino" aria-label='Reply to eduardo quirino'>Reply</a>														</div>
								<div class="comment-text">
					<p>the whole world has been witnessing all the insane and corrupt acts of Mr. Trump</p>
				</div>
			</div></li><!-- #comment-## -->
			</ol>
		</div>		<div class="pagination comments-pagination">
					</div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.sakafete.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='85324' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="af0e8a4153" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="10"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>	</div>
	<aside class="mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<div id="custom_html-5" class="widget_text sb-widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_newsdesk_custom_posts-7" class="sb-widget clearfix mh_newsdesk_custom_posts"><h4 class="widget-title"><span>Random: Flash Back</span></h4>			<div class="mh-cp-widget clearfix">						<article class="cp-wrap cp-large clearfix">
							<div class="cp-thumb-xl">
								<a href="https://www.sakafete.com/scientists-explore-blue-hole-in-the-depths-of-the-florida-seabed/" title="Scientists explore &#8216;blue hole&#8217; in the depths of the Florida seabed"><picture class="attachment-cp-thumb-xl size-cp-thumb-xl wp-post-image" loading="lazy" title="Scientists explore &#039;blue hole&#039; in the depths of the Florida seabed 6">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-120x67.jpg.webp 120w" sizes="(max-width: 373px) 100vw, 373px"/>
<img width="373" height="210" src="https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-373x210.jpg" alt="Scientists explore &#039;blue hole&#039; in the depths of the Florida seabed 6" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/07/sddefault-84-120x67.jpg 120w" sizes="(max-width: 373px) 100vw, 373px"/>
</picture>
								</a>
							</div>
															<p class="entry-meta">
									<span class="updated">July 26, 2020</span>
								</p>
														<h3 class="cp-title-xl">
								<a href="https://www.sakafete.com/scientists-explore-blue-hole-in-the-depths-of-the-florida-seabed/" title="Scientists explore &#8216;blue hole&#8217; in the depths of the Florida seabed" rel="bookmark">
									Scientists explore &#8216;blue hole&#8217; in the depths of the Florida seabed								</a>
							</h3>
							<div class="cp-excerpt-xl">
								<p>&nbsp; &quot;It&#039;s like an oasis in the ocean:&quot; Newly released video shows scientists exploring the depths of a &#039;blue hole&#039; off Florida&#039;s Gulf Coast. Read&#8230;</p>
											<a class="button" href="https://www.sakafete.com/scientists-explore-blue-hole-in-the-depths-of-the-florida-seabed/">
				<span>Get the full scoop</span>
			</a>							</div>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/nadler-mueller-wont-be-pushed-into-defying-subpoena/" title="Nadler: Mueller won&#8217;t be pushed into defying subpoena"><img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Nadler: Mueller won&#039;t be pushed into defying subpoena 7" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2019/06/maxresdefault-85.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px" title="Nadler: Mueller won&#039;t be pushed into defying subpoena 7">								</a>
							</div>
															<p class="entry-meta"><span class="updated">June 27, 2019</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/nadler-mueller-wont-be-pushed-into-defying-subpoena/" title="Nadler: Mueller won&#8217;t be pushed into defying subpoena" rel="bookmark">
									Nadler: Mueller won&#8217;t be pushed into defying subpoena								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/charlamagne-tha-god-kamala-harris-was-terrible-in-debate/" title="Charlamagne tha God: Kamala Harris was &#8216;terrible&#8217; in debate"><img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Charlamagne tha God: Kamala Harris was &#039;terrible&#039; in debate 8" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2019/08/maxresdefault-48.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px" title="Charlamagne tha God: Kamala Harris was &#039;terrible&#039; in debate 8">								</a>
							</div>
															<p class="entry-meta"><span class="updated">August 2, 2019</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/charlamagne-tha-god-kamala-harris-was-terrible-in-debate/" title="Charlamagne tha God: Kamala Harris was &#8216;terrible&#8217; in debate" rel="bookmark">
									Charlamagne tha God: Kamala Harris was &#8216;terrible&#8217; in debate								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/launch-of-skills-training-programme-in-tete-morne/" title="Launch of Skills Training Programme in Tete Morne"><img width="89" height="67" src="https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Launch of Skills Training Programme in Tete Morne 9" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4.jpg 480w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-300x225.jpg 300w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-80x60.jpg 80w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-260x195.jpg 260w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-160x120.jpg 160w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-386x290.jpg 386w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-290x218.jpg 290w, https://www.sakafete.com/wp-content/uploads/2018/11/hqdefault-4-193x145.jpg 193w" sizes="(max-width: 89px) 100vw, 89px" title="Launch of Skills Training Programme in Tete Morne 9">								</a>
							</div>
															<p class="entry-meta"><span class="updated">November 13, 2018</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/launch-of-skills-training-programme-in-tete-morne/" title="Launch of Skills Training Programme in Tete Morne" rel="bookmark">
									Launch of Skills Training Programme in Tete Morne								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/dr-michael-osterholm-number-of-u-s-health-workers-deaths-is-sobering-mtp-daily-msnbc/" title="Dr. Michael Osterholm: Number of U.S. Health Workers Deaths Is &#8216;Sobering&#8217; | MTP Daily | MSNBC"><img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Dr. Michael Osterholm: Number of U.S. Health Workers Deaths Is &#039;Sobering&#039; | MTP Daily | MSNBC 10" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-496.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px" title="Dr. Michael Osterholm: Number of U.S. Health Workers Deaths Is &#039;Sobering&#039; | MTP Daily | MSNBC 10">								</a>
							</div>
															<p class="entry-meta"><span class="updated">July 10, 2020</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/dr-michael-osterholm-number-of-u-s-health-workers-deaths-is-sobering-mtp-daily-msnbc/" title="Dr. Michael Osterholm: Number of U.S. Health Workers Deaths Is &#8216;Sobering&#8217; | MTP Daily | MSNBC" rel="bookmark">
									Dr. Michael Osterholm: Number of U.S. Health Workers Deaths Is &#8216;Sobering&#8217; | MTP Daily | MSNBC								</a>
							</h3>
						</article>
						<hr class="mh-separator">			</div></div></aside></div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
	<div id="custom_html-9" class="widget_text footer-ad-wrap widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div>	<div class="wrapper-inner clearfix">
					<div class="mh-section mh-group footer-widgets">
									<div class="mh-col mh-1-3 footer-1">
						<div id="media_image-2" class="footer-widget widget_media_image"><a href="https://www.review-products.ca/"><img width="360" height="110" src="https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts.png" class="image wp-image-12875  attachment-full size-full" alt="review products" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts.png 360w, https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts-300x92.png 300w" sizes="(max-width: 360px) 100vw, 360px" /></a></div><div id="media_image-3" class="footer-widget widget_media_image"><a href="https://www.estopandshop.com/"><img width="320" height="95" src="https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com.png" class="image wp-image-12876  attachment-full size-full" alt="estop and shop" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com.png 320w, https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com-300x89.png 300w" sizes="(max-width: 320px) 100vw, 320px" /></a></div><div id="media_image-4" class="footer-widget widget_media_image"><a href="https://cakafeteusa.com/"><img width="300" height="100" src="https://www.sakafete.com/wp-content/uploads/2020/01/amazon-prime-deals-deliver-on-time.png" class="image wp-image-32846  attachment-full size-full" alt="amazon prime deals" loading="lazy" style="max-width: 100%; height: auto;" /></a></div>					</div>
													<div class="mh-col mh-1-3 footer-2">
						<div id="mh_newsdesk_recent_posts-4" class="footer-widget mh_newsdesk_recent_posts">			<ul class="mh-rp-widget widget-list">					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/lawrence-another-day-another-trump-vengeance-firing-the-last-word-msnbc/" title="Lawrence: ‘Another Day, Another Trump Vengeance Firing’ | The Last Word | MSNBC" rel="bookmark">
							Lawrence: ‘Another Day, Another Trump Vengeance Firing’ | The Last Word | MSNBC						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/" title="Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC" rel="bookmark">
							Klobuchar On Ouster Of Cyber Official: ‘He Should Never Have Been Fired.’ | The Last Word | MSNBC						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/dr-bhadelia-trump-admin-hurting-people-by-not-sharing-covid-19-info-with-biden-the-last-word/" title="Dr. Bhadelia: Trump Admin. ‘Hurting People’ By Not Sharing Covid-19 Info With Biden | The Last Word" rel="bookmark">
							Dr. Bhadelia: Trump Admin. ‘Hurting People’ By Not Sharing Covid-19 Info With Biden | The Last Word						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/family-reunited-with-dog-missing-since-january/" title="Family reunited with dog missing since January" rel="bookmark">
							Family reunited with dog missing since January						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/we-need-to-be-prepared-now-to-cyber-threats-canadian-centre-for-cyber-security/" title="&#8220;We need to be prepared now&#8221; to cyber threats: Canadian Centre for Cyber Security" rel="bookmark">
							&#8220;We need to be prepared now&#8221; to cyber threats: Canadian Centre for Cyber Security						</a>
					</li>			</ul></div>					</div>
													<div class="mh-col mh-1-3 footer-3">
											</div>
							</div>
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
							<nav class="footer-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
					<div class="menu-submit-container"><ul id="menu-submit-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11407"><a href="https://www.sakafete.com/latest-buzz/">LATEST BUZZ</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1620"><a href="https://www.sakafete.com/dominica-to-open-celebrations-for-reunion-year-2008-with-grand-reunion-wive-activity/">Celebs/Artist News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1621"><a href="https://www.sakafete.com/prime-minister-skerrit-highlights-the-incidence-of-chronic-non-communicable-diseases-in-dominica/">Publication</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1622"><a href="https://www.sakafete.com/myblog-2/">Dominicans Open Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64991"><a href="https://www.sakafete.com/caribbean-tourism-in-the-tropical-islands/">Tourism News</a></li>
</ul></div>				</nav>
						<div class="copyright-wrap">
				<p class="copyright">
					SAKAFETE.COM - Copyright © 1996 - 2019. All Rights Reserved.				</p>
			</div>
		</div>
	</div>
</footer>
			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> 		<div id="amp-mobile-version-switcher" hidden>
			<a rel="amphtml" href="https://www.sakafete.com/klobuchar-on-ouster-of-cyber-official-he-should-never-have-been-fired-the-last-word-msnbc/?amp=1">
				Go to mobile version			</a>
		</div>

				<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script src="https://videopal.me/js/vp_player.min.js?v=1.1.29" data-cfasync="false"></script>
<script>
var vpPlayer = new VpPlayer({
    embedId: "LNsY5WeNsdCu"
});</script>
</body>
</html>
