<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
	<!-- CAKAFETEINC Tracking Code -->
<script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.www.sakafete.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://www.cakafeteinc.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '3']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="https://www.cakafeteinc.com/matomo.php?idsite=3&amp;rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End CAKAFETE Tracking Code -->
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.sakafete.com/wp-content/uploads/2020/05/favicon.ico">
<link rel="pingback" href="https://www.sakafete.com/xmlrpc.php" />
<!-- Global site tag (gtag.js) - Google Analytics Start -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1472193-21"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1472193-21');
</script>
<script>!function(e){var r={};function n(t){if(r[t])return r[t].exports;var o=r[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,n),o.l=!0,o.exports}n.m=e,n.c=r,n.d=function(e,r,t){n.o(e,r)||Object.defineProperty(e,r,{enumerable:!0,get:t})},n.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},n.t=function(e,r){if(1&r&&(e=n(e)),8&r)return e;if(4&r&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(n.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&r&&"string"!=typeof e)for(var o in e)n.d(t,o,function(r){return e[r]}.bind(null,o));return t},n.n=function(e){var r=e&&e.__esModule?function(){return e.default}:function(){return e};return n.d(r,"a",r),r},n.o=function(e,r){return Object.prototype.hasOwnProperty.call(e,r)},n.p="",n(n.s=0)}([function(e,r){!function(e){var r=e.ampUrl,n=e.isCustomizePreview,t=e.isAmpDevMode,o=e.noampQueryVarName,a=e.noampQueryVarValue,i=e.disabledStorageKey,u=e.mobileUserAgents,s=e.regexRegex;if("undefined"!=typeof sessionStorage){var f=new RegExp(s);if(u.some((function(e){var r=e.match(f);if(r&&new RegExp(r[1],r[2]).test(navigator.userAgent))return!0;return navigator.userAgent.includes(e)}))){document.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var r=e.querySelector("a[href]");r&&r.addEventListener("click",(function(){sessionStorage.removeItem(i)}))}}));var c=t&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(i)||n||c)){var d=new URL(location.href),l=new URL(r);l.hash=d.hash,d.searchParams.has(o)&&a===d.searchParams.get(o)?sessionStorage.setItem(i,"1"):l.href!==d.href&&(window.stop(),location.replace(l.href))}}}}({"ampUrl":"https:\/\/www.sakafete.com\/teachers-interactions-with-students-the-best-the-bravest-february-4-2021\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}]);</script>
<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Teachers Interactions With Students: The Best &amp; The Bravest - February 4 2021</title>
<meta name="description" content="Jamaica News Today - Television Jamaica a Trusted Source for News, Sports &amp; Entertainment."/>
<meta name="robots" content="index, nofollow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Teachers Interactions With Students: The Best &amp; The Bravest - February 4 2021">
<meta property="og:description" content="Jamaica News Today - Television Jamaica a Trusted Source for News, Sports &amp; Entertainment.">
<meta property="og:url" content="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/">
<meta property="og:site_name" content="Dominica news online most popular | cakafete">
<meta property="article:publisher" content="https://facebook.com/cakafete">
<meta property="article:author" content="https://facebook.com/cakafete">
<meta property="article:tag" content="Countries">
<meta property="article:tag" content="Entertainment Culture">
<meta property="article:tag" content="Jamaica">
<meta property="article:tag" content="Jamaica News">
<meta property="article:tag" content="jamaica news today">
<meta property="article:tag" content="Jamaican TV">
<meta property="article:tag" content="Kingston, Jamaica">
<meta property="article:tag" content="midday news">
<meta property="article:tag" content="news in jamaica today">
<meta property="article:tag" content="oral Tracey">
<meta property="article:tag" content="prime time news">
<meta property="article:tag" content="smile jamaica">
<meta property="article:tag" content="sports commentary">
<meta property="article:tag" content="Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021">
<meta property="article:tag" content="television jamaica">
<meta property="article:tag" content="TVJ 1Spotmedia">
<meta property="article:tag" content="tvj news">
<meta property="article:tag" content="tvj news 2021">
<meta property="article:tag" content="tvj news 2021 today">
<meta property="article:tag" content="tvj news Today 2021">
<meta property="article:tag" content="tvj news yesterday 2021">
<meta property="article:tag" content="www.youtube.com/watch?v=kzOwB kmhCY">
<meta property="article:section" content="LATEST BUZZ">
<meta property="og:updated_time" content="2021-02-06T04:21:33-05:00">
<meta property="fb:app_id" content="100001021166193">
<meta property="og:image" content="https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg">
<meta property="og:image:secure_url" content="https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg">
<meta property="og:image:width" content="1280">
<meta property="og:image:height" content="720">
<meta property="og:image:alt" content="Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Teachers Interactions With Students: The Best &amp; The Bravest - February 4 2021">
<meta name="twitter:description" content="Jamaica News Today - Television Jamaica a Trusted Source for News, Sports &amp; Entertainment.">
<meta name="twitter:site" content="@cakafete">
<meta name="twitter:creator" content="@cakafete">
<meta name="twitter:image" content="https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg">
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["Organization","Person"],"@id":"https://www.sakafete.com/#person","name":"Fred White","url":"https://www.sakafete.com","email":"news@sakafete.com","logo":{"@type":"ImageObject","url":"https://www.sakafete.com/wp-content/uploads/2018/10/Sakafete-news.png"},"image":{"@type":"ImageObject","url":"https://www.sakafete.com/wp-content/uploads/2018/10/Sakafete-news.png"}},{"@type":"WebSite","@id":"https://www.sakafete.com/#website","url":"https://www.sakafete.com","name":"Fred White","publisher":{"@id":"https://www.sakafete.com/#person"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#primaryImage","url":"https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg","width":"1280","height":"720"},{"@type":"BreadcrumbList","@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.sakafete.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/","name":"Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021"}}]},{"@type":"WebPage","@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#webpage","url":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/","name":"Teachers Interactions With Students: The Best &amp; The Bravest - February 4 2021","datePublished":"2021-02-06T04:21:26-05:00","dateModified":"2021-02-06T04:21:33-05:00","isPartOf":{"@id":"https://www.sakafete.com/#website"},"primaryImageOfPage":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#primaryImage"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#breadcrumb"}},{"@type":"BlogPosting","headline":"Teachers Interactions With Students: The Best &amp; The Bravest - February 4 2021","datePublished":"2021-02-06T04:21:26-05:00","dateModified":"2021-02-06T04:21:33-05:00","author":{"@type":"Person"},"publisher":{"@id":"https://www.sakafete.com/#person"},"description":"Jamaica News Today - Television Jamaica a Trusted Source for News, Sports &amp; Entertainment.","@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#richSnippet","isPartOf":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#webpage"},"image":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#primaryImage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//www.sakafete.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Feed" href="https://www.sakafete.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Comments Feed" href="https://www.sakafete.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dominica news online most popular | cakafete &raquo; Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021 Comments Feed" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sakafete.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.sakafete.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpbloom-css'  href='https://www.sakafete.com/wp-content/plugins/bloom/public/css/wpbloom-public.css?ver=1.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='one-click-video-site-builder-front-css'  href='https://www.sakafete.com/wp-content/plugins/one-click-video-site-builder/assets/css/front.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='https://www.sakafete.com/wp-content/themes/mh_newsdesk/style.css?ver=1.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.sakafete.com/wp-content/themes/mh_newsdesk/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700%7cOswald:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/bloom/public/js/wpbloom-public.js?ver=1.5.1' id='wpbloom-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/one-click-video-site-builder/assets/js/front.js?ver=1.4' id='one-click-video-site-builder-front-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=5.6.1' id='mh-scripts-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-1472193-21' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.sakafete.com"]} );
gtag('js', new Date());
gtag('config', 'UA-1472193-21');
</script>
<link rel="https://api.w.org/" href="https://www.sakafete.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sakafete.com/wp-json/wp/v2/posts/104138" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sakafete.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sakafete.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.1" />
<link rel='shortlink' href='https://www.sakafete.com/?p=104138' />
<link rel="alternate" type="application/json+oembed" href="https://www.sakafete.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sakafete.com%2Fteachers-interactions-with-students-the-best-the-bravest-february-4-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sakafete.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sakafete.com%2Fteachers-interactions-with-students-the-best-the-bravest-february-4-2021%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.24.0" />	<meta name="keywords" content="Countries, Entertainment Culture, Jamaica, Jamaica News, jamaica news today, Jamaican TV, Kingston, Jamaica, midday news, news in jamaica today, oral Tracey, prime time news, smile jamaica, sports commentary, Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021, television jamaica, TVJ 1Spotmedia, tvj news, tvj news 2021, tvj news 2021 today, tvj news Today 2021, tvj news yesterday 2021, www.youtube.com/watch?v=kzOwB kmhCY" />
<!--[if lt IE 9]>
<script src="https://www.sakafete.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="amphtml" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/amp/"><style>#amp-mobile-version-switcher {
	position: absolute;
	width: 100%;
	left: 0;
	z-index: 100;
}

#amp-mobile-version-switcher > a {
	display: block;
	padding: 15px 0;
	font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;
	font-size: 16px;
	font-weight: 600;
	color: #eaeaea;
	text-align: center;
	text-decoration: none;
	background-color: #444;
	border: 0;
}

#amp-mobile-version-switcher > a:hover,
#amp-mobile-version-switcher > a:focus,
#amp-mobile-version-switcher > a:active {
	text-decoration: underline;
}
</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/?amp=1"><link rel="icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.sakafete.com/wp-content/uploads/2016/08/cropped-Sakafeteicon-270x270.png" />
</head>
<body class="post-template-default single single-post postid-104138 single-format-video mh-right-sb mh-loop-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div id="mh-wrapper">
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo">
			<a href="https://www.sakafete.com/" title="Dominica news online most popular | cakafete" rel="home">
<div class="logo-wrap" role="banner">
<div class="logo">
<h1 class="logo-title">Dominica news online most popular | cakafete</h1>
<h2 class="logo-tagline">Local, Reginald and International Latest News</h2>
</div>
</div>
</a>
		</div>
		<aside id="custom_html-6" class="widget_text mh-col mh-2-3 widget_custom_html"><div class="widget_text header-ad"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Review Products -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="8380539043"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>	</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-submit-container"><ul id="menu-submit" class="menu"><li id="menu-item-11407" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11407"><a href="https://www.sakafete.com/latest-buzz/">LATEST BUZZ</a></li>
<li id="menu-item-1620" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1620"><a href="https://www.sakafete.com/dominica-to-open-celebrations-for-reunion-year-2008-with-grand-reunion-wive-activity/">Celebs/Artist News</a></li>
<li id="menu-item-1621" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1621"><a href="https://www.sakafete.com/prime-minister-skerrit-highlights-the-incidence-of-chronic-non-communicable-diseases-in-dominica/">Publication</a></li>
<li id="menu-item-1622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1622"><a href="https://www.sakafete.com/myblog-2/">Dominicans Open Blogs</a></li>
<li id="menu-item-64991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64991"><a href="https://www.sakafete.com/caribbean-tourism-in-the-tropical-islands/">Tourism News</a></li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<div id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">
			Hot Topics		</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/our-approves-jps-new-rate-class-tvj-business-day-february-4-2021/" title="OUR Approves JPS New Rate Class: TVJ Business Day &#8211; February 4 2021">
					<span class="ticker-item-date">February 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">OUR Approves JPS New Rate Class: TVJ Business Day &#8211; February 4 2021</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/mother-daughter-face-court-for-murder-in-st-mary-jamaica-february-4-2021/" title="Mother &amp; Daughter Face Court for Murder in St. Mary, Jamaica &#8211; February 4 2021">
					<span class="ticker-item-date">February 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Mother &amp; Daughter Face Court for Murder in St. Mary, Jamaica &#8211; February 4 2021</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/indecom-wants-jail-block-at-rcjcc-closed-february-4-2021/" title="INDECOM Wants Jail Block at RCJCC Closed &#8211; February 4 2021">
					<span class="ticker-item-date">February 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">INDECOM Wants Jail Block at RCJCC Closed &#8211; February 4 2021</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/" title="Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021">
					<span class="ticker-item-date">February 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.sakafete.com/tvj-news-jamaica-news-headlines-february-4-2021/" title="TVJ News: Jamaica News Headlines &#8211; February 4 2021">
					<span class="ticker-item-date">February 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">TVJ News: Jamaica News Headlines &#8211; February 4 2021</span>
				</a>
			</li>	</ul>
</div>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="https://www.sakafete.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header>
<div class="mh-section mh-group">
	<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-104138" class="post-104138 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz category-publications tag-countries tag-entertainment-culture tag-jamaica tag-jamaica-news tag-jamaica-news-today tag-jamaican-tv tag-kingston-jamaica tag-midday-news tag-news-in-jamaica-today tag-oral-tracey tag-prime-time-news tag-smile-jamaica tag-sports-commentary tag-teachers-interactions-with-students-the-best-the-bravest-february-4-2021 tag-television-jamaica tag-tvj-1spotmedia tag-tvj-news tag-tvj-news-2021 tag-tvj-news-2021-today tag-tvj-news-today-2021 tag-tvj-news-yesterday-2021 tag-www-youtube-com-watchvkzowb-kmhcy post_format-post-format-video">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021		</h1><div class="entry-tags clearfix"><span>TOPICS:</span><a href="https://www.sakafete.com/tag/countries/" rel="tag">Countries</a><a href="https://www.sakafete.com/tag/entertainment-culture/" rel="tag">Entertainment Culture</a><a href="https://www.sakafete.com/tag/jamaica/" rel="tag">Jamaica</a><a href="https://www.sakafete.com/tag/jamaica-news/" rel="tag">Jamaica News</a><a href="https://www.sakafete.com/tag/jamaica-news-today/" rel="tag">jamaica news today</a><a href="https://www.sakafete.com/tag/jamaican-tv/" rel="tag">Jamaican TV</a><a href="https://www.sakafete.com/tag/kingston-jamaica/" rel="tag">Kingston, Jamaica</a><a href="https://www.sakafete.com/tag/midday-news/" rel="tag">midday news</a><a href="https://www.sakafete.com/tag/news-in-jamaica-today/" rel="tag">news in jamaica today</a><a href="https://www.sakafete.com/tag/oral-tracey/" rel="tag">oral Tracey</a><a href="https://www.sakafete.com/tag/prime-time-news/" rel="tag">prime time news</a><a href="https://www.sakafete.com/tag/smile-jamaica/" rel="tag">smile jamaica</a><a href="https://www.sakafete.com/tag/sports-commentary/" rel="tag">sports commentary</a><a href="https://www.sakafete.com/tag/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/" rel="tag">Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021</a><a href="https://www.sakafete.com/tag/television-jamaica/" rel="tag">television jamaica</a><a href="https://www.sakafete.com/tag/tvj-1spotmedia/" rel="tag">TVJ 1Spotmedia</a><a href="https://www.sakafete.com/tag/tvj-news/" rel="tag">tvj news</a><a href="https://www.sakafete.com/tag/tvj-news-2021/" rel="tag">tvj news 2021</a><a href="https://www.sakafete.com/tag/tvj-news-2021-today/" rel="tag">tvj news 2021 today</a><a href="https://www.sakafete.com/tag/tvj-news-today-2021/" rel="tag">tvj news Today 2021</a><a href="https://www.sakafete.com/tag/tvj-news-yesterday-2021/" rel="tag">tvj news yesterday 2021</a><a href="https://www.sakafete.com/tag/www-youtube-com-watchvkzowb-kmhcy/" rel="tag">www.youtube.com/watch?v=kzOwB kmhCY</a></div>	</header>
<div class="entry-thumbnail">
<img width="777" height="437" src="https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-777x437.jpg" class="attachment-content-single size-content-single wp-post-image" alt="Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021 1" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg 1280w" sizes="(max-width: 777px) 100vw, 777px" title="Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021 1"></div>
<div id="custom_html-7" class="widget_text sb-widget post-ad post-ad-1 widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><p class="entry-meta">
<span class="entry-meta-date updated">February 6, 2021</span>
</p>
	<div class="entry-content clearfix">
		<p>    <span class="ytg-video-container"            style="max-height: 360px"    >          <iframe class="ytg-video-player"    allowfullscreen      src="//www.youtube.com/embed/kzOwB_kmhCY?autoplay=0&amp;rel=1&amp;iv_load_policy=1"  ></iframe>    </span>  </p>
<p>&nbsp;</p>
<p>Jamaica News Today &#8211; Television Jamaica a Trusted Source for News, Sports &amp; Entertainment.</p>
<p>Television Jamaica (TVJ) where you get Jamaican news, sports and weather reports and an eclectic mix of music, entertainment and information shows for the entire family. TVJ programme offerings reflect the music, icons, cultures and lifestyles of today&#039;s Jamaican youth, and the interests and values of younger and older audiences, providing great viewing for the entire family.</p>
<p>SHARE AND SUBSCRIBE &#8211; </p>
<p>For more TVJ videos visit &#8211; </p>
<p>Trusted News<br />
For access to LIVE TV go to </p>
<p>For TVJ Merchandise &amp; Fan Gear : </p>
<p>#tvjnews #jamaicanewstoday</p>
<div class="ytg-video-url">
<p><iframe title="Teachers Interactions with Students: The Best &amp; the Bravest - February 4 2021" width="777" height="437" src="https://www.youtube.com/embed/kzOwB_kmhCY?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
	</div>
	<div id="custom_html-8" class="widget_text sb-widget post-ad post-ad-2 widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div></article><div class="mh-share-buttons mh-group">
    <a class="mh-col mh-1-4 mh-facebook" href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/&t=Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
	    <span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span>
	</a>
    <a class="mh-col mh-1-4 mh-twitter" href="#" onclick="window.open('http://twitter.com/share?text=Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021 -&url=https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
	    <span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span>
	</a>
    <a class="mh-col mh-1-4 mh-pinterest" href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/&media=https://www.sakafete.com/wp-content/uploads/2021/02/maxresdefault-389.jpg&description=Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
	    <span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span>
	</a>
    <a class="mh-col mh-1-4 mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
	    <span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span>
	</a>
</div><nav class="post-nav-wrap" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="https://www.sakafete.com/tvj-news-jamaica-news-headlines-february-4-2021/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
<li class="post-nav-next">
<a href="https://www.sakafete.com/indecom-wants-jail-block-at-rcjcc-closed-february-4-2021/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li>
</ul>
</nav>
		<h4 class="widget-title related-content-title">
			<span>Related Articles</span>
		</h4>
		<div class="related-content clearfix"><article class="mh-col mh-1-4 content-grid post-93773 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz category-publications tag-countries tag-entertainment-culture tag-jamaica tag-jamaica-news tag-jamaican-tv tag-kingston-jamaica tag-midday-news tag-news-in-jamaica-today tag-oral-tracey tag-prime-time-news tag-smile-jamaica tag-sports-commentary tag-television-jamaica tag-tvj-1spotmedia tag-tvj-intense-december-12-2020 tag-tvj-news tag-tvj-news-2020 tag-tvj-news-2020-today tag-tvj-news-today-2020 tag-tvj-news-yesterday-2020 tag-www-youtube-com-watchvlrbnkhdczbm post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/tvj-intense-december-12-2020/" title="TVJ Intense &#8211; December 12 2020"><picture class="attachment-content-grid size-content-grid wp-post-image" loading="lazy" title="TVJ Intense - December 12 2020 2">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925.jpg.webp 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
<img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-180x101.jpg" alt="TVJ Intense - December 12 2020 2" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-925.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
</picture>
		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/tvj-intense-december-12-2020/" title="TVJ Intense &#8211; December 12 2020" rel="bookmark">
			TVJ Intense &#8211; December 12 2020		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-82029 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz category-publications tag-countries tag-entertainment-culture tag-jamaica tag-jamaica-news tag-jamaican-tv tag-kingston-jamaica tag-midday-news tag-news-in-jamaica-today tag-oral-tracey tag-player tag-prime-time-news tag-reggae tag-reggae-girlz-bunny-shaw-nominated-for-player-of-the-month-of-october-novemtner-5-2020 tag-smile-jamaica tag-sports-commentary tag-television-jamaica tag-tvj-1spotmedia tag-tvj-news tag-tvj-news-2020 tag-tvj-news-2020-today tag-tvj-news-today-2020 tag-tvj-news-yesterday-2020 tag-www-youtube-com-watchvscbigcbab5u post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/reggae-girlz-bunny-shaw-nominated-for-player-of-the-month-of-october-novemtner-5-2020/" title="Reggae Girlz &#8220;Bunny&#8221; Shaw Nominated for Player of the Month of October &#8211; Novemtner 5 2020"><picture class="attachment-content-grid size-content-grid wp-post-image" loading="lazy" title="Reggae Girlz &quot;Bunny&quot; Shaw Nominated for Player of the Month of October - Novemtner 5 2020 3">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490.jpg.webp 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
<img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-180x101.jpg" alt="Reggae Girlz &quot;Bunny&quot; Shaw Nominated for Player of the Month of October - Novemtner 5 2020 3" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/11/maxresdefault-490.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
</picture>
		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/reggae-girlz-bunny-shaw-nominated-for-player-of-the-month-of-october-novemtner-5-2020/" title="Reggae Girlz &#8220;Bunny&#8221; Shaw Nominated for Player of the Month of October &#8211; Novemtner 5 2020" rel="bookmark">
			Reggae Girlz &#8220;Bunny&#8221; Shaw Nominated for Player of the Month of October &#8211; Novemtner 5 2020		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-80210 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz category-publications tag-countries tag-entertainment-culture tag-jamaica tag-jamaica-news tag-jamaican-tv tag-kingston-jamaica tag-midday-news tag-news-in-jamaica-today tag-oral-tracey tag-prime-time-news tag-smile-jamaica tag-sports-commentary tag-television-jamaica tag-tvj-1spotmedia tag-tvj-news tag-tvj-news-2020 tag-tvj-news-2020-today tag-tvj-news-today-2020 tag-tvj-news-yesterday-2020 tag-tvj-sports-commentary-october-28-2020 tag-www-youtube-com-watchvewvkpchnqpe post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/tvj-sports-commentary-october-28-2020/" title="TVJ Sports Commentary &#8211; October 28 2020"><picture class="attachment-content-grid size-content-grid wp-post-image" loading="lazy" title="TVJ Sports Commentary - October 28 2020 4">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840.jpg.webp 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
<img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-180x101.jpg" alt="TVJ Sports Commentary - October 28 2020 4" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/10/maxresdefault-1840.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
</picture>
		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/tvj-sports-commentary-october-28-2020/" title="TVJ Sports Commentary &#8211; October 28 2020" rel="bookmark">
			TVJ Sports Commentary &#8211; October 28 2020		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-72275 post type-post status-publish format-video has-post-thumbnail hentry category-latest-buzz category-publications tag-countries tag-entertainment-culture tag-international-organizations tag-jamaica tag-jamaica-news tag-jamaican-tv tag-kingston-jamaica tag-midday-news tag-news-in-jamaica-today tag-oral-tracey tag-prime-time-news tag-smile-jamaica tag-sports-commentary tag-television-jamaica tag-tvj-1spotmedia tag-tvj-entertainment-report-top-10-countdown-september-18-2020 tag-tvj-news tag-tvj-news-2020 tag-tvj-news-2020-today tag-tvj-news-today-2020 tag-tvj-news-yesterday-2020 tag-world tag-www-youtube-com-watchv2ocbuask-bi post_format-post-format-video">
	<div class="content-thumb content-grid-thumb">
		<a href="https://www.sakafete.com/tvj-entertainment-report-top-10-countdown-september-18-2020/" title="TVJ Entertainment Report: Top 10 Countdown &#8211; September 18 2020"><picture class="attachment-content-grid size-content-grid wp-post-image" loading="lazy" title="TVJ Entertainment Report: Top 10 Countdown - September 18 2020 5">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055.jpg.webp 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
<img width="180" height="101" src="https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-180x101.jpg" alt="TVJ Entertainment Report: Top 10 Countdown - September 18 2020 5" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/09/maxresdefault-2055.jpg 1280w" sizes="(max-width: 180px) 100vw, 180px"/>
</picture>
		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="https://www.sakafete.com/tvj-entertainment-report-top-10-countdown-september-18-2020/" title="TVJ Entertainment Report: Top 10 Countdown &#8211; September 18 2020" rel="bookmark">
			TVJ Entertainment Report: Top 10 Countdown &#8211; September 18 2020		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator">		</div><div class="comments-wrap">
<h4 class="comment-section-title"><span class="comment-count">Be the first to comment</span> <span class="comment-count-more">on "Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021"</span></h4>
</div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.sakafete.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='104138' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5fa8d3a574" /></p><input type="hidden" id="ak_js" name="ak_js" value="144"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>	</div>
	<aside class="mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<div id="custom_html-5" class="widget_text sb-widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_newsdesk_custom_posts-7" class="sb-widget clearfix mh_newsdesk_custom_posts"><h4 class="widget-title"><span>Random: Flash Back</span></h4>			<div class="mh-cp-widget clearfix">						<article class="cp-wrap cp-large clearfix">
							<div class="cp-thumb-xl">
								<a href="https://www.sakafete.com/greg-gutfeld-destroys-obama-obama-scared-of-trump-92016/" title="Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16"><img width="336" height="210" src="https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92.jpg" class="attachment-cp-thumb-xl size-cp-thumb-xl wp-post-image" alt="Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16 6" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92.jpg 1280w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-300x188.jpg 300w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-768x480.jpg 768w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-1024x640.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-153x96.jpg 153w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-170x106.jpg 170w, https://www.sakafete.com/wp-content/uploads/2016/09/maxresdefault-92-50x31.jpg 50w" sizes="(max-width: 336px) 100vw, 336px" title="Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16 6">								</a>
							</div>
															<p class="entry-meta">
									<span class="updated">September 20, 2016</span>
								</p>
														<h3 class="cp-title-xl">
								<a href="https://www.sakafete.com/greg-gutfeld-destroys-obama-obama-scared-of-trump-92016/" title="Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16" rel="bookmark">
									Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16								</a>
							</h3>
							<div class="cp-excerpt-xl">
								<p>&nbsp; Greg Gutfeld Destroys Obama! Obama Scared of Trump! 9/20/16 Fox News &#8211; The Five &#8211; Greg Gutfeld destroys Obama &#8211; Obama Scared of Trump&#8230;</p>
											<a class="button" href="https://www.sakafete.com/greg-gutfeld-destroys-obama-obama-scared-of-trump-92016/">
				<span>Get the full scoop</span>
			</a>							</div>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/new-zealand-vs-west-indies-december-5-2020/" title="New Zealand vs West Indies &#8211; December 5 2020"><picture class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" loading="lazy" title="New Zealand vs West Indies - December 5 2020 7">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477.jpg.webp 1280w" sizes="(max-width: 120px) 100vw, 120px"/>
<img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-120x67.jpg" alt="New Zealand vs West Indies - December 5 2020 7" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/12/maxresdefault-477.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px"/>
</picture>
								</a>
							</div>
															<p class="entry-meta"><span class="updated">December 8, 2020</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/new-zealand-vs-west-indies-december-5-2020/" title="New Zealand vs West Indies &#8211; December 5 2020" rel="bookmark">
									New Zealand vs West Indies &#8211; December 5 2020								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/long-serving-conservative-mp-says-scheer-punished-him-for-breaking-ranks-on-legal-pot/" title="Long-serving Conservative MP says Scheer punished him for breaking ranks on legal pot"><img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Long-serving Conservative MP says Scheer punished him for breaking ranks on legal pot 8" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/01/maxresdefault-13.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px" title="Long-serving Conservative MP says Scheer punished him for breaking ranks on legal pot 8">								</a>
							</div>
															<p class="entry-meta"><span class="updated">January 1, 2020</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/long-serving-conservative-mp-says-scheer-punished-him-for-breaking-ranks-on-legal-pot/" title="Long-serving Conservative MP says Scheer punished him for breaking ranks on legal pot" rel="bookmark">
									Long-serving Conservative MP says Scheer punished him for breaking ranks on legal pot								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/questions-raised-about-role-of-outside-groups-in-local-protests-mtp-daily-msnbc/" title="Questions Raised About Role Of Outside Groups In Local Protests | MTP Daily | MSNBC"><img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Questions Raised About Role Of Outside Groups In Local Protests | MTP Daily | MSNBC 9" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/06/maxresdefault-43.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px" title="Questions Raised About Role Of Outside Groups In Local Protests | MTP Daily | MSNBC 9">								</a>
							</div>
															<p class="entry-meta"><span class="updated">June 1, 2020</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/questions-raised-about-role-of-outside-groups-in-local-protests-mtp-daily-msnbc/" title="Questions Raised About Role Of Outside Groups In Local Protests | MTP Daily | MSNBC" rel="bookmark">
									Questions Raised About Role Of Outside Groups In Local Protests | MTP Daily | MSNBC								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://www.sakafete.com/faa-issues-emergency-notice-about-boeing-737/" title="FAA issues emergency notice about Boeing 737"><picture class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" loading="lazy" title="FAA issues emergency notice about Boeing 737 10">
<source type="image/webp" srcset="https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-120x67.jpg.webp 120w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-300x169.jpg.webp 300w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-1024x576.jpg.webp 1024w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-768x432.jpg.webp 768w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-777x437.jpg.webp 777w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-180x101.jpg.webp 180w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-260x146.jpg.webp 260w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-373x210.jpg.webp 373w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110.jpg.webp 1280w" sizes="(max-width: 120px) 100vw, 120px"/>
<img width="120" height="67" src="https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-120x67.jpg" alt="FAA issues emergency notice about Boeing 737 10" loading="lazy" srcset="https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-120x67.jpg 120w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-300x169.jpg 300w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-1024x576.jpg 1024w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-768x432.jpg 768w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-777x437.jpg 777w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-180x101.jpg 180w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-260x146.jpg 260w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110-373x210.jpg 373w, https://www.sakafete.com/wp-content/uploads/2020/07/maxresdefault-1110.jpg 1280w" sizes="(max-width: 120px) 100vw, 120px"/>
</picture>
								</a>
							</div>
															<p class="entry-meta"><span class="updated">July 24, 2020</span></p>
														<h3 class="cp-title-small">
								<a href="https://www.sakafete.com/faa-issues-emergency-notice-about-boeing-737/" title="FAA issues emergency notice about Boeing 737" rel="bookmark">
									FAA issues emergency notice about Boeing 737								</a>
							</h3>
						</article>
						<hr class="mh-separator">			</div></div></aside></div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
	<div id="custom_html-9" class="widget_text footer-ad-wrap widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div>	<div class="wrapper-inner clearfix">
					<div class="mh-section mh-group footer-widgets">
									<div class="mh-col mh-1-3 footer-1">
						<div id="media_image-2" class="footer-widget widget_media_image"><a href="https://www.review-products.ca/"><img width="360" height="110" src="https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts.png" class="image wp-image-12875  attachment-full size-full" alt="review products" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts.png 360w, https://www.sakafete.com/wp-content/uploads/2019/06/New-logo-reviewproducts-300x92.png 300w" sizes="(max-width: 360px) 100vw, 360px" /></a></div><div id="media_image-3" class="footer-widget widget_media_image"><a href="https://www.estopandshop.com/"><img width="320" height="95" src="https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com.png" class="image wp-image-12876  attachment-full size-full" alt="estop and shop" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com.png 320w, https://www.sakafete.com/wp-content/uploads/2019/06/visit-estopandshop-dot-com-300x89.png 300w" sizes="(max-width: 320px) 100vw, 320px" /></a></div><div id="media_image-4" class="footer-widget widget_media_image"><a href="https://cakafeteusa.com/"><img width="300" height="100" src="https://www.sakafete.com/wp-content/uploads/2020/01/amazon-prime-deals-deliver-on-time.png" class="image wp-image-32846  attachment-full size-full" alt="amazon prime deals" loading="lazy" style="max-width: 100%; height: auto;" /></a></div>					</div>
													<div class="mh-col mh-1-3 footer-2">
						<div id="mh_newsdesk_recent_posts-4" class="footer-widget mh_newsdesk_recent_posts">			<ul class="mh-rp-widget widget-list">					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/our-approves-jps-new-rate-class-tvj-business-day-february-4-2021/" title="OUR Approves JPS New Rate Class: TVJ Business Day &#8211; February 4 2021" rel="bookmark">
							OUR Approves JPS New Rate Class: TVJ Business Day &#8211; February 4 2021						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/mother-daughter-face-court-for-murder-in-st-mary-jamaica-february-4-2021/" title="Mother &amp; Daughter Face Court for Murder in St. Mary, Jamaica &#8211; February 4 2021" rel="bookmark">
							Mother &amp; Daughter Face Court for Murder in St. Mary, Jamaica &#8211; February 4 2021						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/indecom-wants-jail-block-at-rcjcc-closed-february-4-2021/" title="INDECOM Wants Jail Block at RCJCC Closed &#8211; February 4 2021" rel="bookmark">
							INDECOM Wants Jail Block at RCJCC Closed &#8211; February 4 2021						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/" title="Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021" rel="bookmark">
							Teachers Interactions with Students: The Best &amp; the Bravest &#8211; February 4 2021						</a>
					</li>					<li class="rp-widget-item">
						<a href="https://www.sakafete.com/tvj-news-jamaica-news-headlines-february-4-2021/" title="TVJ News: Jamaica News Headlines &#8211; February 4 2021" rel="bookmark">
							TVJ News: Jamaica News Headlines &#8211; February 4 2021						</a>
					</li>			</ul></div>					</div>
													<div class="mh-col mh-1-3 footer-3">
											</div>
							</div>
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
							<nav class="footer-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
					<div class="menu-submit-container"><ul id="menu-submit-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11407"><a href="https://www.sakafete.com/latest-buzz/">LATEST BUZZ</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1620"><a href="https://www.sakafete.com/dominica-to-open-celebrations-for-reunion-year-2008-with-grand-reunion-wive-activity/">Celebs/Artist News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1621"><a href="https://www.sakafete.com/prime-minister-skerrit-highlights-the-incidence-of-chronic-non-communicable-diseases-in-dominica/">Publication</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1622"><a href="https://www.sakafete.com/myblog-2/">Dominicans Open Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64991"><a href="https://www.sakafete.com/caribbean-tourism-in-the-tropical-islands/">Tourism News</a></li>
</ul></div>				</nav>
						<div class="copyright-wrap">
				<p class="copyright">
					SAKAFETE.COM - Copyright © 1996 - 2019. All Rights Reserved.				</p>
			</div>
		</div>
	</div>
</footer>
			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> 		<div id="amp-mobile-version-switcher" hidden>
			<a rel="amphtml" href="https://www.sakafete.com/teachers-interactions-with-students-the-best-the-bravest-february-4-2021/?amp=1">
				Go to mobile version			</a>
		</div>

				<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/comment-reply.min.js?ver=5.6.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.sakafete.com/wp-includes/js/wp-embed.min.js?ver=5.6.1' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.sakafete.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script src="https://videopal.me/js/vp_player.min.js?v=1.1.29" data-cfasync="false"></script>
<script>
var vpPlayer = new VpPlayer({
    embedId: "LNsY5WeNsdCu"
});</script>
</body>
</html>
